Temporary reg data display interruption

Incident Report for eventPower

Resolved

The team has reviewed reporting and related date and we are considering this incident completed.
Posted Apr 24, 2026 - 15:30 EDT

Monitoring

We have completed the review of previously deleted records. All reporting should be back to normal.

Our team is continuing to audit any changes to ensure 100% reporting consistency. Please reach out to your eventPower contact if you continue to see any anomalies.

Thank you for your patience.
Posted Apr 24, 2026 - 12:36 EDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 24, 2026 - 09:28 EDT

Identified

We recently experienced a brief display issue with registration data.  Beginning at approximately 5:05pm EDT on Thursday, registration reports were reporting zero attendees.  Basic reporting features were restored by 5:50pm, though some previously deleted attendee records were continuing to be displayed in reports.

You may continue to see some previously deleted records reflected in your reports and financials.  We are auditing these previously deleted records currently, and expect to have all the reports back to normal by later this morning (Friday).

We will update this status within the next 2-3 hours.
Posted Apr 24, 2026 - 09:27 EDT
This incident affected: eventPower Tools.