Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 01, 2025 - 22:00 EST
Scheduled
We have scheduled maintenance occurring on Saturday 2/29 between 10pm and midnight EST. We anticipate little if no impact to users during this timeframe. You may notice occasional slow response times.
Please contact your eventPower contact or devs@eventpower.com with any questions or concerns.
Posted Feb 26, 2025 - 08:21 EST
This scheduled maintenance affected: eventPower Tools, eP API, Websites, and ShoApp.