ShoApp Login Issues

Incident Report for eventPower

Resolved

We are considering this issue resolved. Thank you for your patience.
Posted Jul 13, 2026 - 16:02 EDT

Monitoring

A fix has been implemented and the team is monitoring for any other issues.
Posted Jul 13, 2026 - 15:09 EDT

Investigating

We have received some reports regarding difficulties logging into and accessing ShoApp. The team is looking into this now.
Posted Jul 13, 2026 - 14:58 EDT
This incident affected: ShoApp.