Service Unavailability.

Incident Report for eventPower

Resolved

This incident has been resolved. All services are fully operational.
Posted Apr 23, 2026 - 09:25 EDT

Update

Some services have been restored. We will continue to communicate updates.
Posted Apr 23, 2026 - 09:13 EDT

Investigating

Service Unavailability
Posted Apr 23, 2026 - 09:05 EDT
This incident affected: eventPower Tools, eP API, Websites, and ShoApp.