Tools Issues

Incident Report for eventPower

Resolved

We are considering this issue resolved.

Please reach out to support@eventpower.com if you continue to experiencing any issues.
Posted Jul 06, 2025 - 20:15 EDT

Update

We have restored functionality and are continuing to test and validate the system components.

We appreciate your patience during this time and will continue to provide updates here.
Posted Jul 06, 2025 - 19:00 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 06, 2025 - 17:32 EDT

Update

Thank you for your patience as we're continuing to work on this issue. We have confirmed the nature of the hardware failure and are working towards recovery and resolution as quickly as possible.

We will continue to update this page with additional information.
Posted Jul 06, 2025 - 17:30 EDT

Update

We are continuing to work with our hosting provider to resolve this issue.

We will provide another update in approximately 30 minutes.

(Correction to prior update, this issue is not affecting the eP API service)
Posted Jul 06, 2025 - 16:29 EDT

Identified

We are working with our hosting provider to resolve this issue. The team is working to resolve the issue and we anticipate resolution shortly. We will provide an update in about 30 minutes.
Posted Jul 06, 2025 - 15:56 EDT

Investigating

We are currently investigating reported issues which is affecting the Tools server. This includes registration, speaker management, exhibits, and APIs.
Posted Jul 06, 2025 - 15:46 EDT
This incident affected: eventPower Tools, eP API, Websites, and ShoApp.